.

Selenium 3 | Key points to note before you start using


The long wait for Selenium 3 is over. Version 3.0.0-beta1 of WebDriver was released last week.








At first glance, it is looking good and so far no issues have been observed in our current tests.

Key points to know before you use Selenium 3.

1. Selenium 3.X is no longer capable of running Selenium RC directly, rather it does it through emulation and the WebDriverBackedSelenium interface.

2. Java 8 is required.

3. Firefox binary is required. 

4.  MarionetteDriver is deprecated. You should use FirefoxDriver with capability marionette = true or false.


1
2
3
4
5
6
 System.setProperty("webdriver.gecko.driver",
    "C:\\Work\\WORK\\Selenium\\geckodriver.exe");
  DesiredCapabilities capabilities = DesiredCapabilities.firefox();
  capabilities.setCapability("marionette", true);
  WebDriver driver = new FirefoxDriver(capabilities);
  driver.get("http://www.google.com")
 

We are in process of checking various suites on web and mobile. We will upload our findings soon.

You can also share your experience in comments section. 

1 comment :

  1. I am unable to run my android and iOS automation suite with selenium 3.X beta version, Please provide suitable answer.

    Configuration:
    Appium 1.5.1 version
    Selenium: 3.X beta Version.

    Anything you required, please do let me know.

    ReplyDelete

Recent Posts