.

ISSUE | SOLVED - No distributions at all found for robotframework-python3

Error :

C:\Users\kamal>pip install robotframework-python3

Collecting robotframework-python3

Could not find any downloads that satisfy the requirement robotframework-python3
No distributions at all found for robotframework-python3


You may see this error if you have Python 3+ installed on your machine and you are trying to install Robot framework. 


Solution :

Robot Framework 2.8 and older support Python 2.5, 2.6, and 2.7, but Robot Framework 2.9 will drop Python 2.5 support. The plan is to support Python 3 in the future, latest with Robot Framework 3.0. If you need Python 3 support earlier, you can use the un-official Python 3 port.

1. Download Robot for python3 from the link above and unzip.

2. Open Command prompt, and change the directory in cmd to unzipped folder where you find setup.py.

3. Type  this command and hit enter.
python setup.py install

This will install robot framework for python 3.



How to check version :
command :> pybot --version
 



1 comment :

  1. I really appreciate information shared above. It’s of great help. If someone want to learn Online (Virtual) instructor lead live training in Robot framework, kindly contact us http://www.maxmunus.com/contact
    MaxMunus Offer World Class Virtual Instructor led training on Robot framework. We have industry expert trainer. We provide Training Material and Software Support. MaxMunus has successfully conducted 100000+ trainings in India, USA, UK, Australlia, Switzerland, Qatar, Saudi Arabia, Bangladesh, Bahrain and UAE etc.
    For Demo Contact us:
    Name : Arunkumar U
    Email : arun@maxmunus.com
    Skype id: training_maxmunus
    Contact No.-+91-9738507310
    Company Website –http://www.maxmunus.com



    ReplyDelete

Recent Posts